We have the following arrangement across the top:

SE banner with links

However, when I logged in earlier today, I got this (I was logged in as I could post comments, etc):

SE banner without links

I've seen this happen a few times. Why is this happening?

  • Have you tried a hard refresh?
    – wax eagle
    Jun 20 '12 at 13:08
  • 2
    Yes (CTRL + F5). It didn't work before I posted this question.
    – user527
    Jun 20 '12 at 13:11
  • I closed my web browser, got your notification a few mins ago, and found the banner to be normal again. It seems to be hit or miss.
    – user527
    Jun 20 '12 at 13:12
  • And I just tried it again (from meta sports to sports) and blank banner comes up again. Another hard refresh doesn't do the trick. Using IE8, FYI.
    – user527
    Jun 20 '12 at 13:13
  • 1
    @edmastermind29: I would consider asking this again on meta.stackoverflow.com. You'll get more visibility on there.
    – Matt
    Jun 22 '12 at 9:45
  • @Matt Funny thing is....it doesn't happen on SO. But perhaps a flag for migration?
    – user527
    Jun 22 '12 at 12:34
  • Meh, I wouldn't flag it, I'd just ask it again and delete this one. It might be worth trying a different browser (Chrome?) to see if it's just IE related or not.
    – Matt
    Jun 22 '12 at 12:37
  • Yeah....but even with IE, it's hit or miss, so I'll try a different browser and see if it duplicates.
    – user527
    Jun 22 '12 at 12:38
  • Just to be clear, does it happen only when clicking the "Main" link at the top of Meta or does it happen when visiting the main site directly? Jun 22 '12 at 15:27
  • It also happens when visiting the main site directly.
    – user527
    Jun 22 '12 at 15:29
  • Can you try other beta sites, like History or [libraries.se]? Jun 22 '12 at 15:36
  • Same thing on History....blank banner.
    – user527
    Jun 22 '12 at 15:38

Well, I found out what's going on.

When compatibility mode on IE 8+ is off, then the banner appears as normal.

When compatibilitiy mode is on, the banner disappears.

You must log in to answer this question.